materiel.net   

Auteur Sujet: Activer le mode AHCI dans le BIOS par Flying_dutchman  (Lu 2490 fois)

Hors ligne Doc.Jeckill

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 17624
  • Sexe: Homme
    • Gagner de l'argent sur internet
    • E-mail
Activer le mode AHCI dans le BIOS par Flying_dutchman
« le: 15 mars 2010 à 20:00:51 »
Activer le mode AHCI dans le BIOS après avoir installé XP / Vista / Seven

Pas grave Doc! j'avais pas bien chercher Google je pense :-[. J'ai trouvé un tuto tout fait. Je le recopie au cas ou le tuto est supprimé. Au démarrage W7 détecte un nouveau perif, on redémarre et hop!  :thumbsup:

-------------------------------------------------------------------------------------------------   
[Tutoriel] Activer le mode AHCI dans le BIOS après avoir installé XP / Vista / Seven

Bonjour à tous

Voici un tutorial ayant pour but de vous permettre d'activer l'AHCI dans le BIOS après avoir installé Windows XP / Windows Vista / Windows 7.

Mais qu'est-ce-que l'AHCI

L'Advanced Host Controller Interface (AHCI) est un mécanisme matériel permettant à la couche logicielle de communiquer avec des périphériques SATA tels que les adaptateurs de bus hôte, qui sont conçus pour offrir des vitesses de transfert supérieures et des fonctionnalités que ne proposent pas les contrôleurs ATA standards, tels que le branchement à chaud ou encore le NCQ.

En tout premier lieu, vous pouvez dors et déjà essayer d'activer l'AHCI directement via le BIOS, sans rien toucher à votre OS.
Si vous bootez correctement, cela veut dire que tout va bien.

Néanmoins, ce post s'adresse à ceux qui rencontrent des soucis avec l'activation de l'AHCI, en effet, si vous n'avez pas installé ou activé les pilotes nécessaires, vous aurez le droit à un bel écran bleu au démarrage de votre OS favoris

La procédure pour Windows XP vous est détaillée sur le site de TT-Hardware

Pour Windows Vista / Windows Seven

L'activation de l'AHCI dans le BIOS ne vous a apporté qu'un bel écran bleu ? Pas de panique, il est très simple de regler ce problème, il suffit juste de réactiver le pilote correspondant, en effet durant l'installation de Windows Vista / Seven, tout pilote de stockage non utilisé est désactivé. Cela permet d'accélérer la procédure de démarrage du système d'exploitation. Lorsque vous remplacez le lecteur de démarrage par un pilote qui a été désactivé, vous devez activer ce nouveau pilote avant de modifier la configuration matérielle.

Ceci est à faire avant d'activer l'AHCI dans le BIOS.

1.Fermez toutes les applications Windows

2.Cliquez sur Démarrer, tapez regedit dans la zone Démarrer la recherche, puis appuyez sur ENTRÉE.

3.Si la boîte de dialogue Contrôle de compte d'utilisateur s'affiche, cliquez sur Continuer.

4.Recherchez la sous-clé de Registre suivante et cliquez dessus : HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\msahci

5.Dans le volet droit, cliquez avec le bouton droit sur la clé Start, dans la colonne Nom, puis cliquez sur Modifier.

6.Dans la zone Données de la valeur, tapez 0, puis cliquez sur OK.

7.Dans le menu Fichier, cliquez sur Quitter pour quitter l'Éditeur du Registre.

Et voila, vous pouvez redémarrer votre ordinateur et activer l'AHCI enhanced dans le BIOS sans soucis

-------------------------------------------------------------------------------------------------

A ++  ;)
Vous pouvez contribuer à la vie du forum en faisant un don via Paypal:


Hors ligne STEELWARE

  • Donateur
  • Membre Junior
  • **
  • Messages: 81
  • Sexe: Homme
    • E-mail
Activer le mode AHCI dans le BIOS par Flying_dutchman
« Réponse #1 le: 11 novembre 2013 à 21:02:19 »
Bonsoir bonsoir,

Ma question va peut-être paraître un peu stupide, cependant comme je ne saisis pas très bien ce que j'ai à l'écran je préfère la poser :)

En installant un logiciel de défragmentation, celui-ci m'a indiqué dès son lancement que mon SSD présent fonctionnait en mode IDE et qu'il était plus que préférable de le passer en AHCI.
En me renseignant un peu sur le net j'ai pu comprendre qu'effectivement ce mode était meilleur si l'on pouvait l'activer en terme de performance.
En faisant une petite recherche sur le forum pour voir s'il était mentionné, je suis tombé sur ce petit tutoriel que j'ai suivi à la lettre. Tout s'est déroulé comme indiqué, et j'ai bien fais le redémarrage une fois que Windows a trouvé ou installé tous les pilotes...

Cependant j'ai pu noter qu'à présent au démarrage la carte mère réalisait un nouveau test en rapport avec les disques durs, c'est très rapide mais à la fin de chaque ligne (3 en tout comme j'ai 1 SSD et 2 HDD) je peux distinguer "S.MA.R.T. : OK".
Je ne sais pas ce que cela signifie mais ma question n'est pas là.

Lorsque je vais dans le BIOS dans l'onglet "Démarrage" pour l'ordre / ou voir les périphériques connectés il y a maintenant "IDE" au début de la ligne du SSD.
Dois-je comprendre que l'AHCI est bien activé mais qu'il fonctionne toujours en mode IDE ? :/



Je vous remercie d'avance pour vos réponses et vous souhaite une bonne soirée ! :)

Hors ligne Doc.Jeckill

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 17624
  • Sexe: Homme
    • Gagner de l'argent sur internet
    • E-mail
Activer le mode AHCI dans le BIOS par Flying_dutchman
« Réponse #2 le: 11 novembre 2013 à 22:12:08 »
Bizarre  :perplexe:
La première image indique que 4 ports sata 3 sont en AHCI mais la deuxième indique que ton SSD est en IDE.
As-tu bien branché le SSD sur le premier port SATA 3 ?
Si oui, fais un clear Cmos e reconfigure le BIOS...
Vous pouvez contribuer à la vie du forum en faisant un don via Paypal:


Hors ligne pmloikju

  • Co Admin
  • Membre Héroïque
  • *****
  • Messages: 4388
  • Sexe: Homme
    • E-mail
Activer le mode AHCI dans le BIOS par Flying_dutchman
« Réponse #3 le: 11 novembre 2013 à 23:21:27 »
Il me semble que cette carte mére indique IDE tout le temps pour la seconde photo, mais je n'ai pas mon pc devant les yeux pour être certain.
Si tu en as le courage; Alors formate .



                                  
Full AMD

Hors ligne STEELWARE

  • Donateur
  • Membre Junior
  • **
  • Messages: 81
  • Sexe: Homme
    • E-mail
Activer le mode AHCI dans le BIOS par Flying_dutchman
« Réponse #4 le: 11 novembre 2013 à 23:59:17 »
Le SSD est bien sur le port 1.
Et j'ai pu voir qu'elle avait ajouté IDE devant chaque DD branché en fait.

En fouillant un peu sur le net je suis tombé sur des forums où des personnes avaient le même "problème", ça rejoindrait ce que pmloikju dit, la CM continuerait d'indiquer IDE et le met même devant tous les DD. :/

Hors ligne Doc.Jeckill

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 17624
  • Sexe: Homme
    • Gagner de l'argent sur internet
    • E-mail
Activer le mode AHCI dans le BIOS par Flying_dutchman
« Réponse #5 le: 12 novembre 2013 à 14:02:38 »
En fait tous les disques sont IDE qui veut dire Integrated Drive Electronics tout simplement. Rien à voir avec les standart de fonctionnement AHCI et "as IDE". Tu es donc bien en AHCI mais la carte mère appelle ton SSD IDE (Integrated Drive Electronics) + le nom du disque   ;)
Vous pouvez contribuer à la vie du forum en faisant un don via Paypal:


Hors ligne STEELWARE

  • Donateur
  • Membre Junior
  • **
  • Messages: 81
  • Sexe: Homme
    • E-mail
Activer le mode AHCI dans le BIOS par Flying_dutchman
« Réponse #6 le: 12 novembre 2013 à 17:43:34 »
Tout va bien alors, merci pour la précision :)

Hors ligne deledav

  • Néophyte
  • *
  • Messages: 30
  • Sexe: Homme
    • E-mail
Activer le mode AHCI dans le BIOS par Flying_dutchman
« Réponse #7 le: 08 janvier 2015 à 18:11:01 »
Super je ne connaissais pas, je vais pouvoir l'appliquer dès que je reçois mon pc si ils ne l'ont pas fait après montage.

Hors ligne Doc.Jeckill

  • Administrateur
  • Membre Héroïque
  • *****
  • Messages: 17624
  • Sexe: Homme
    • Gagner de l'argent sur internet
    • E-mail
Activer le mode AHCI dans le BIOS par Flying_dutchman
« Réponse #8 le: 08 janvier 2015 à 18:45:17 »
Super je ne connaissais pas, je vais pouvoir l'appliquer dès que je reçois mon pc si ils ne l'ont pas fait après montage.

Maintenant, toute les cartes sont activées par défaut avec l'AHCI  :D
Vous pouvez contribuer à la vie du forum en faisant un don via Paypal: